openssl重大安全性問題

根據openssl的公告: https://www.openssl.org/news/secadv_20140407.txt
因openssl出現重大安全性問題,有相當多現行的伺服器會受到影響,這算是最嚴重等級的資安bug,對於有提供HTTPS, Webmail, VPNs的服務業者影響尤大(光Https就涵蓋相當多)。

可以使用我們下列的教學,進行更新,以免遭遇駭客攻擊。

繼續閱讀 openssl重大安全性問題

如何在centOS上,透過yum安裝基本的web server

有的客戶因為要跑相對比較吃硬碟I/O數的遊戲,喜歡不裝cpanel。但是不裝cpanel的話,剛拿到的centOS是連完整的web server環境都沒有的。本文就是來講解,如何在一台乾淨的centOS上,透過yum安裝基本的web server

(*) 安裝web server
1 for php
yum install php

2 for ioncube loader ( ioncube loader是一個跟加密的php source code有關的模組,不灌這個的話,如果要執行的插件是有加密的php source code,就跑不動了。)
wget -q -O – http://www.atomicorp.com/installers/atomic |sh
yum install php-ioncube-loader

3 for mysql
yum install mysql mysql-server php-mysql
chkconfig –levels 235 mysqld on
/etc/init.d/mysqld start
修改mysql的 password
/usr/bin/mysqladmin -u root password ‘你要設定給mysql root的密碼

4 for httpd
yum install httpd
service httpd restart