如何快速解決因為升級php版本,導致的程式問題呢?

近年來,php更新速度太快,導致早期開發的網站程式,可能因為新舊函式庫的相容性問題,因而導致網站無法應用的窘況,現在為了解決這樣的狀況,並可以先給修改程式一個緩衝,我們提供可自選php版本的方式。

繼續閱讀 如何快速解決因為升級php版本,導致的程式問題呢?

主機商選購指南

本篇文章是一篇帶有強烈置入性行銷的文章。請大家多多包涵。

作為一個主機商,由於客戶中有許多常常三天兩頭有被DDoS, 被放木馬之類的問題,本公司在累積了無數的經驗(?客訴)之後, 對於安全性的議題有著異常的執著與重視。要提高安全性,確保php程式碼沒有漏洞的部分,是客戶端在管的。但是,要確保php的版本沒有漏洞的部分,則是主機商的事。

升級php, 升級mysql, 升級apache, 更換ip,這一類的事,由於會影響到客戶的程式,對於主機商而言算是苦差事。但是,不升級也不行。不升級的話,漏洞就會一直存在。是否應該升級?何時最好一定要升級,其實這個問題,也是有客觀的參考。

以美國的五大主機商為例子,hostgatorwebhostingpad都已經升級PHP 5.3了。( 這些資訊,我是直接用官網去查的 )

而台灣地區,搜尋「虛擬主機」這個關鍵字,google出來第一頁的主機商之中,大間的5、6家裡,幾乎都還是使用PHP 5.2.17版。(台灣的同胞怎麼這麼不重視資訊安全啊? 這不是已經應該要升級很久了嗎? )只有一家有升級PHP 5.3。這一家,呃,當然不是敝公司,因為unethost.com的google rank在很多頁之後。但是,本公司升級PHP 5.3是老早以前的事。官網的主機已經升級到 PHP 5.3.22版了。

最後要在這邊順便講解一下,如何看php的版本。如果是用chrome來當browser 的話,先按Ctrl + shift + i,選Network,按F5,之後,點選一個php網頁。看到最下方,應該會有一串字串 X-Powered-By:,例如:

X-Powered-By: PHP/5.3.22

這就是了!