wordpress 升級所發生的狀況

wordpress_issue_wp

wordpress 是現在最方便使用的 cms 系統,
尤其後台所內建的,插件及版模雲端安裝功能,廣受大眾喜愛。

 

版模及插件的問題
使用者可以在後台挑選額外的功能(插件),
或不同的網頁版模,很容易就可建立起一個網站。

不過其實相關的功能,大多都不是官方所推出的,
所以很可能造成主程式一升級後,其插件和版模就會異常。

 

以下就是升級wp主程式後,結果網頁版模不匹配,導致首頁無法開啟;
wp經過多年的改版,所以會把 error狀況顯示清楚。
wp_issue_01

根據上圖,由客戶的服務單詢問後,我們根據錯誤訊息的路逕,
告知是版模出錯,後來客戶由wp後台登入後,
在去升級版模即恢復正常。

所以不同版本的版模,會導致錯誤狀況。

 

插件的問題
通常同一套wp裡面,或多或少都有數個插件;
在升級插件時,不建議一次全部更新,

而是一套套個別更新,確定沒問題後,在更新下一套。
因為很可能,就會遇到其中有一套插件出問題,
最嚴重將會導致後台也無法登入,這時就要靠備份來搶救。


結論:
無論是升級主程式,插件,版模;
盡量都在升級前,做一個最新的備份,以確保萬無一失。

(本篇教學由unethost.com客服撰寫)

延伸閱讀:如何備份Cpanel後台安裝的套裝程式?

延伸閱讀:更多wordpress的介紹

安裝上述的軟體,我們提供虛擬主機試用,七天滿意保證,
功能完整使用不受限制,歡迎點我申請。

透過linux shell 的 grep 指令找出特定的編碼(找出網頁被強制轉址)

如何操作 linux grep 指令,搜索內文或是匯出。

我們曾在之前的一篇裡,介紹過操作 linux shell 裡的 grep 用法。

其實舉凡網頁內的特定內容,都可以使用 grep 去搜索出路逕。

請看我們下列的示範說明:

繼續閱讀 透過linux shell 的 grep 指令找出特定的編碼(找出網頁被強制轉址)

如何透過cpanel安裝ssl,讓網址可以使用https?(測試模式)

ssl_wp

本次教學,是透過cpanel設置網域的ssl,讓網址可以使用https,
但這是自己對自己發送憑證的方式,因為沒有支付額外的授權金,
所以瀏覽器會彈出如上圖的警告訊息。(最後結論有安全性概念)

繼續閱讀 如何透過cpanel安裝ssl,讓網址可以使用https?(測試模式)

如何找出網站開啟速度慢的原因(或是網站疑似被駭)

developer_tools_wp

偶爾會有客戶反應,為什麼他們的網站速度不順呢?
當排除不是由server loading或是線路問題引起時,
可能要重新回頭觀察網站內容,包含程式碼或是圖片的讀取狀況。

下列是我們使用 firefox 的開發者工具,來查看並盡可能協助處理這樣的問題。

(直接使用 blog.unethost.com 當範例)

繼續閱讀 如何找出網站開啟速度慢的原因(或是網站疑似被駭)